Sometimes orders may run into errors displayed on the Fulfillment Dashboard when syncing Onfleet orders. Please review the list below for more information.
Error:
completeBefore must not be before creation time Invalid time constraints specified
Description:
This error occurs when the scheduled time of the SellTreez ticket has lapsed before the Onfleet Task was created.
Cause:
This can happen for a few reasons:
An integration partner may have submitted the "scheduled_date" for a date or time in the past.
A scheduled time was set in SellTreez or by an integration partner, but the date or time has since passed before the ticket was moved to an order status that triggers the onfleet integration to create an Onfleet task.
Resolution:
Navigate to SellTreez POS
Click "Current Sale"
Click "View Saved Sales"
Search for the Order number
Click the order
Click "Edit"
Update the Date and/or time to one in the future