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METRC Error Glossary

Learn more about the METRC errors you see in Compliance Management!

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Written by Treez Admin
Updated over 2 weeks ago
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The ‘To Do’ tab on the METRC Control page shows you all the sales and adjustments (or ‘tasks’) that encountered an error when sent from your Treez portal to METRC. When a task is rejected by METRC, it is accompanied by an error message that includes details from METRC with the reason for why the task wasn’t received successfully. This is shown in the ‘Error Message’ column of the main table.

If you’re scratching your head reading some of the errors, not to worry! We’ve compiled a list of the error messages below with information about what may cause them and how to resolve each one.

A sale may include more than one error. This is because the different packages on the sale may each have different errors. If this is the case, address each package’s error one at a time.

NOTE: If you see an error that is not on this list, please send it to [email protected] and our team will investigate and assist.

Error Glossary

Error

  • <METRCITEMNAME> requires Unit THC Percent - Colorado Medical Only 2022

Cause

Licensees are required to update their existing items within the following categories to include Unit THC Content, Unit Weight, or THC %.

If this is not updated, you will receive the following error in Compliance Management:

In the example below, there are 3 items in this error message (Wonder Monkey Bud", Wedding Pie Bud" and Peechy Keen Bud"), all with the same error, so the true error is "Item '<METRCITEMNAME>' requires Unit THC Percent".

Screenshot_1.png

Resolution

NOTE: If you are a vertically integrated operator, you will need to go into your Distribution License Portal in METRC, then go to "Admin" from the drop-down menu.

To update existing items please use the following steps:

1. Go to the Items section of METRC, which you will find under the ADMIN tab
2. Within the Items section, find all items under the categories outlined above
3. Once the item(s) that will need to be updated are found, select the “Edit Items” button

Screenshot_2.png

4. Select the item(s) to be edited, the Edit Items action window will pop up as shown below
and enter the Unit THC Content for that item.

Screenshot_3.png

5. After confirming the accuracy of the information entered within the Unit THC Content, select the
“Save Items” button.
6. The item will be updated accordingly, and the newly entered Unit THC Content will be
visible within the item’s grid.

Screenshot_4.png

TIP: You can find more information here - METRC Support Bulletin

NOTE: If you have products by 3rd party vendors which have not been updated by that vendor, you will need to manually upload the sales into METRC and dismiss the sales from METRC control in Treez.

If you have updated the THC and unit weight fields for your distribution license your sales will push into METRC from Treez. Only dismiss sales that were manually uploaded into METRC due to the vendor not updating these fields.

Screenshot_2.png

If a licensee has not updated their items by January 1st, there will still be the ability for the Medical Store licensee to input that information to mitigate any items from being sold to a patient within the licensees existing inventory. This does require that you upload in real time for MEDICAL sales.

Screenshot_1.png

Error

  • Package 1234567890 does not exist in the current Facility.

  • Package 1234567890 is in Transit and cannot have its contents sold.

  • Package 1234567890 cannot be adjusted because it is part of an existing Transfer.

  • Sales Receipt 0 does not exist in the current facility.

Cause
When a sale, return, or adjustment is unable to be recorded in METRC because the package has been transferred out of the facility license, these error messages will display.

Resolution
If you encounter these errors, we recommend contacting METRC support for further instructions Typically you will need to upload these sales manually by exporting the sales and removing the packages that no longer exist in your facility. Don't forget to Dismiss the affected sales and adjustments on the METRC Control page after you have exported and uploaded them manually. Learn more about exporting and uploading sales or adjustments to METRC via CSV by following these instructions.

When a package that has been transferred out appears on the True Up page, it will be unable to be trued-up because the adjustment will be rejected by METRC with one of the errors above. If you encounter this, ensure you have permanently hidden the package.

TIP: To ensure the transferred out package won’t continue being sold, remove any remaining items from Treez by using the Return function in Inventory Control, if you haven’t already.


Error

  • 401 - undefined

Cause
This error means your METRC API Key is valid but does not have the appropriate permissions to report sales or adjustments.

Resolution
When you see these errors, you will need to update the permissions for the METRC user whos key your are using to report your sales and adjustments.

To report non-delivery sales, ensure the API Key has the Manage Sales permission in METRC under Admin > Employees.

To report inventory adjustment, ensure the APUI key has the Manage Sales permission in METRC under Admin > Employees.

Image of the Manage Inventory permission in METRC under Admin &gt; Employees

After your credentials are updated, the sales and adjustments with this error will be able to be resent from the METRC Control page.


Error

  • Authorization has been denied for this request

Cause
This error means the METRC API Key used to communicate with METRC is invalid. Keys can be invalidated if a user regenerates their METRC API key in the METRC UI as each user can only have a single METRC API key at any given time. METRC API Keys can also become invalid if the current key was associated with a METRC user who has been deactivated or otherwise removed from your METRC account.

Resolution
When you see these errors, you’ll need to update your integration credentials. METRC Admins can view their current key or generate an API Key by logging into METRC and clicking on the dropdown arrow (next to their username) in the upper right-hand corner of the screen and then selecting API Keys.

Image of the user menu in METRC with API Keys option highlighted

If there is a key on this page, you should not have to generate a new one, simply copy the API Key.

Image of Current API Key section in METRC API Keys page


Navigate back to Treez, and go to Configurations > Config Page > Integration > State Tracking and enter the API Key into the field.

NOTE: You also need to ensure that the API key used here has the correct permissions. We also suggest using the METRC Administrators API key as they should have all 'Manage' permissions in METRC which allow for integration METRC functionality. Updating an API Key that does not have the appropriate permissions may result in additional failed sales and failure to resend previously failed sales.

After your credentials are updated, the sales and adjustments with this error will be able to be resent from the METRC Control page.


Error

  • Package 1234567890 cannot be adjusted below negative quantity threshold.

Cause
METRC will not allow package adjustments that will result in the package quantity becoming a negative amount and respond with this error.

Resolution
Generally, packages will not reach a negative quantity unless action has been taken directly in METRC causing the METRC quantity to differ (lower in this case) than the Treez quantity. Follow these steps to investigate and identify the discrepancy between Treez and METRC, and then resend the errored tasks from the METRC Control page.


Error

  • Contents from package 1234567890 cannot be sold because it has been Finished.

Cause
METRC recommends ‘finishing’ packages when they’ve sold out. Though this isn’t a required action, it keeps your list of packages in METRC more organized and can also help your METRC portal to run faster. When packages reach 0 quantity for 7 consecutive days, Treez automatically finishes the package via the API. Typically, Treez will automatically attempt to unfinish a package if a sale or adjustments needs to be reported while hte package is finished.

Resolution
Generally, packages will not reach 0 until all sales and adjustments are sent from Treez to METRC, unless action has been taken directly in METRC making the METRC quantity lower than the Treez quantity. Follow these steps to investigate and identify the discrepancy between Treez and METRC, and then resend the errored tasks from the METRC Control page.


Error

  • Cannot insert the value NULL into column 'ReceiptNumber'

Cause
This error means that for unknown reasons, METRC was unable to assign a Receipt Number to a sale when it was processing it into their system.

Resolution
Because ‘ReceiptNumber’ is a sale identifier assigned by METRC, Treez will be unable to fill the details required to send the sale successfully. If you encounter this error, contact METRC for assistance. In the meantime, you have a couple of options for resolution:

  • The issue may have been temporary or intermittent, so you can retry sending these sales from the METRC Control page. You can find full instructions on how to do so here.

  • The issue may also only be affecting the API, so you can also instead follow the steps here to make the needed corrections and upload the tasks to METRC via CSV, and then Dismiss them from METRC Control.

  • You can also wait for METRC support to respond with a definitive answer on how to get the sales into their system.


Error

  • Execution Timeout Expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

  • Timeout expired. The timeout period elapsed prior to obtaining a connection from the pool. This may have occurred because all pooled connections were in use and max pool size was reached.

  • A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections.

  • MSDTC on server 'ORD-MTC-CA-SQL1' is unavailable.

  • Error: connect ETIMEDOUT 50.57.237.18:443

  • Error: read ECONNRESET

  • 500 - … errors

  • 502 - … errors

  • 503 - … errors

  • 504 - … errors

Cause
These errors are caused by an issue with METRC’s database, server, or API connections. Meaning, METRC has become unable to accept tasks sent from Treez. This is typically a transient or temporary issue at the time Treez attempts to report an integrated METRC action such as a sale or adjustment.

Resolution
Sales and adjustments with these errors should be resent from the METRC Control page. You can find full instructions on how to do so here.


Error

  • Patient Number is required, but was not specified.

Cause

This error occurs when your METRC market is configured to require a Patient License Number (sometimes referred to as MMID, MMIC or Medical ID) when submitted sales to medical patients but the medical ID was not entered in the customers Treez profile.

Resolution

These sales cannot be resent successfully from METRC Control and will need to be manually uploaded to METRC via CSV. follow the steps here to make the needed corrections and upload the tasks to METRC via CSV.

You'll want to ensure that the customers Medical ID number is entered into their Treez profile so future sales do not result in the same error.


Error

  • Package 1234567890 cannot be sold by [Unit of Measure], because it is not compatible with [Unit of Measure].

  • The Unit of Measure is invalid. Valid values are: [Unit of Measure]

Cause
These errors indicate that the data sent by Treez to METRC had invalid (missing or incorrect) details. However, they should only appear in rare cases. When they occur, our team will further investigate each issue to determine its exact cause and make any updates to prevent them moving forward.

Resolution
If you see these errors, please contact Treez Support so our team can investigate what caused the invalid information on the sale or adjustment and make any necessary fixes. In the meantime, these tasks won’t be able to be resent from METRC Control because the invalid details require manual correction. Instead, follow the steps here to make the needed corrections and upload the tasks to METRC via CSV.


Error

  • Package 1234567890 has been discontinued and cannot have its contents sold.

Cause
When a package is ‘discontinued’ in METRC, it is eliminated permanently from your METRC portal. Discontinue actions cannot be reverted. The Treez API never discontinues packages, so this error would be caused by the manual action of discontinuing the package in your METRC portal.

Resolution
Because there is no way to un-discontinue a package, you’ll be unable to record any sales on it. If you encounter this error, contact METRC for guidance on next steps.


Error

  • Could not allocate space for object 'dbo.Commits'.'PK_Commits' in database 'metrc-prod-ca-events' because the 'PRIMARY' filegroup is full. Create disk space by deleting unneeded files, dropping objects in the filegroup, adding additional files to the filegroup, or setting autogrowth on for existing files in the filegroup.

Cause
This is a database error indicates the target METRC database is full and needs to have space added or files deleted to make space for new data to be written.

Resolution
This error is usually temporary while METRC addresses the space issues their database is experiencing. Typically, you can resend this sale or adjustment within a few hours. If you encounter this error for an extended period of time, contact METRC for assistance.


Error

  • Facility can not sell to External Patients.

Cause
METRC has determined that the Patient Identification number associated with this sale is considered an External Patient and your license does not allow you to sell to external patients. If the customer is indeed a registered medical patient in your state, it is possible the Medical ID on their Treez profile was entered incorrectly.

Resolution
These sales typically cannot be resent from Compliance Management unless your license permission is updated by METRC to allow sales to external patients and may need to be uploaded manually to METRC. If you believe this patient is not an external patient, you can verify that the State Medical ID number is entered correctly in the Customer Profile. If it is not, update the State Medical ID number as soon as possible to prevent issues with future sales to this patient. You will then need to export the sale from Compliance Management and enter the correct State Medical ID number in the export as well as update the "Customer Type" field in the export with the appropriate verbiage for patients in your METRC state, usually "Patient". If the customer is an external patient and you experience this error, contact METRC for assistance with manually reporting this sale or updating your license permissions in METRC to allow sales to external patients.


Error

  • Sales Receipt 0 does not exist in the current facility

Image of Sales Receipts 0 does not exists in current Facility error in METRC Control

Cause

This error indicates an update job attempting to report a sale that has already been reported.

Solution

You can dismiss this sale from the TODO tab in METRC Control. The sale has already been uploaded to METRC.


Error

Error: write EPROTO 140059133101952:error:14094410:SSL routines:ssl3_read_bytes:sslv3 alert handshake failure:../deps/openssl/openssl/ssl/record/rec_layer_s3.c:1544:SSL alert number 40

Screenshot_8.png

Cause

This error indicates there was an issue recording the reported action in METRC.

Solution

It is safe to resend this to METRC.


Error

" Identification Method is required but was not specified."

Image of Identification Method is required but was not specified error in METRC Control

Cause

This error indicates that the sale was sent as an External Patient and your METRC market requires an Identification Method to be submitted correctly for sales External Patients

If you believe the customer is NOT an External Patient (External Patients are medical customers visiting form another reciprocity State), the Medical ID entered into their Treez profile was not found in METRC and was likely entered incorrectly, cause the patient to be reported as an External Patient. The Medical ID number could also have been returned as Inactive by METRC meaning the patients Medical ID has expired.

If the customer IS an External Patient, the Medical ID State was not entered in their profile.

Solution

If the customer IS an External Patient, report he sale(s) manually in METRC as 'External Patient', ensuring you are using the correct Identification Method for your METRC Market. Please refer to your markets METRC documentation for accepted Identification Method formats.

If the customer is NOT an External Patient, report the sale manually in METRC as 'Patient', ensuring you are using the correct, valid Medical ID. Then ensure the Medical ID is updated in the Customers Treez profile to prevent future failed sales and incorrect patient type reporting.

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